अध्याय 11
क्लाइंट, ग्रुपवेयर & CLI
एडमिन:
#pOverview
कैलेंडर & संपर्क, CalDAV/CardDAV & मोबाइल पुश के साथ nextxch Webmail PWA
केवल प्रोटोकॉल वाले मेल बैकएंड के विपरीत, nextxch एक तेज़, इंस्टॉल करने योग्य Webmail PWA (/mail/) के साथ आता है, जिसमें पूर्ण ग्रुपवेयर कैलेंडर (माह, सप्ताह, दिन और एजेंडा व्यू, साथ-साथ ओवरलैप लेआउट और मिनी कैलेंडर के साथ), प्रोफ़ाइल इंस्पेक्टर वाले विज़ुअल संपर्क कार्ड, नोट्स और कार्य हैं - सभी ठीक उसी स्टोर पर आधारित हैं जिस पर CalDAV, CardDAV और मोबाइल पुश।
संचालन सुझाव और आर्किटेक्चर नोट
हर ग्रुपवेयर इंटरफ़ेस एक एकीकृत रीयल-टाइम स्टोर साझा करता है: Webmail में ईवेंट या संपर्क कार्ड बनाते ही वह तुरंत iPhone (ActiveSync WBXML या CalDAV/CardDAV), macOS, Android और Thunderbird पर पुश हो जाता है।
Well-Known डिस्कवरी & सिंक्रनाइज़ेशन एंडपॉइंट
आधुनिक क्लाइंट (iOS, macOS, Thunderbird, DAVx5) केवल https://mail.company.com का उपयोग करके सभी कलेक्शन स्वचालित रूप से खोज लेते हैं।
Webmail PWA (inkl. Kalender & Kontakte): https://mail.firma.de/mail/
CalDAV Auto-Discovery (RFC 6764 / 4791): https://mail.firma.de/.well-known/caldav
CardDAV Auto-Discovery (RFC 6764 / 6352): https://mail.firma.de/.well-known/carddav
Mobile Push (WBXML / EAS 12.1-16.1): https://mail.firma.de/Microsoft-Server-ActiveSync
JMAP Session (RFC 8620 / 8621): https://mail.firma.de/.well-known/jmap
सेटिंग्स, डिफ़ॉल्ट मान और बेस्ट प्रैक्टिस
| सेटिंग / स्थान | विवरण | डिफ़ॉल्ट मान | उत्पादन बेस्ट प्रैक्टिस |
|---|---|---|---|
Webmail Kalender (/mail/ -> Kalender) |
माह, 7-दिवसीय सप्ताह, दिन और एजेंडा व्यू, ISO सप्ताह संख्या, मिनी कैलेंडर, पूरे दिन की पंक्ति और ईवेंट इंस्पेक्टर के साथ विज़ुअल ग्रुपवेयर कैलेंडर। | Integriert auf Port 443 |
सप्ताह दृश्य पर जाने के लिए किसी भी सप्ताह संख्या पर क्लिक करें, या नई अपॉइंटमेंट पहले से भरने के लिए किसी भी टाइम स्लॉट पर क्लिक करें। |
Webmail Kontaktkarten (/mail/ -> Kontakte) |
रंगीन आद्याक्षर अवतार, A-Z जंप बार, त्वरित खोज, Card/Compact टॉगल और दाईं ओर प्रोफ़ाइल इंस्पेक्टर के साथ लोग दृश्य। | CardDAV vCard 3.0/4.0 + GAL |
संपर्क कार्ड पर स्वचालित रूप से साफ़ भूमिका बैज दिखाने के लिए संगठन को 'Company · Department' के रूप में प्रारूपित करें। |
CalDAV & CardDAV (/dav/) |
RFC 6578 sync-collection टोकन के साथ कैलेंडर (VEVENT), कार्य (VTODO), नोट (VJOURNAL) और पता पुस्तिकाओं (VCARD) के लिए ओपन-स्टैंडर्ड एक्सेस। | Aktiv (/.well-known/*) |
2FA-सुरक्षित खातों के लिए प्रति-डिवाइस ऐप पासवर्ड बनाएँ, क्योंकि नेटिव CalDAV/CardDAV क्लाइंट HTTP Basic के माध्यम से प्रमाणित होते हैं। |
JMAP für Dateien (FileNode) |
JMAP (draft-ietf-jmap-filenode के अनुसार urn:ietf:params:jmap:filenode) के ज़रिए फ़ाइलें, टीम फ़ोल्डर और साझा फ़ोल्डर, संस्करणों, कोटा और बदलावों पर पुश के साथ। | /.well-known/jmap |
यह मानक अभी भी IETF ड्राफ़्ट है; FileNode सपोर्ट वाले क्लाइंट दुर्लभ हैं। Explorer और Finder में ड्राइव के लिए WebDAV ही सामान्य तरीका बना हुआ है। |
Mobile Push (ActiveSync:Enabled) |
स्वतंत्र क्लीन-रूम WBXML पुश इंजन, जो HTTPS 443 पर मेल, कैलेंडर, संपर्क, नोट, कार्य, अनुपस्थिति (Out-of-Office) और टेनेंट GAL सिंक करता है। | true (Aktiv) |
सुनिश्चित करें कि रिवर्स प्रॉक्सी लंबे समय तक चलने वाले Ping कनेक्शन के लिए /Microsoft-Server-ActiveSync पर >= 900s रीड टाइमआउट की अनुमति दें। |